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Getting Started 

Installation 
To install the software onto your PC: 

1. Place the Actinic installation CD in your CD drive. 

2. It should automatically run. If it does not, you will need to: 

• Click the 'Start' button in Windows taskbar and go to 
'Run'. 

• Click 'Browse' and then go to 'D:' (where D: is your CD 
drive). 

3. Select 'setup.exe' and double click. 

This will start the first of the 'Installation Wizards' that will guide you 
through the set-up process. It is possible to achieve a perfectly 
satisfactory installation by accepting all the default settings suggested to 
you. Click 'Next' to take you from screen to screen, click 'Back' to take 
you to the previous screen and click 'Cancel' to abort the installation 
process. 
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Starting Actinic 
Actinic is designed to publish an online store onto the internet, and then 
receive and process orders from that store. 

It works by taking all your product data and turning it into a set of web 
pages, based on the design options you have selected. It then also 
manages all the functionality to control the shopping cart, search and 
online security at your online store. 

When you first start Actinic, you will see the following screen: 

 

If you have a license key for Actinic, enter it in the field provided and 
click 'Authorise'. 

If you want to evaluate Actinic then you need to select one of the 
'Evaluation Version' options at the bottom half of the window.  

• To evaluate Actinic Catalog, or Actinic Business select the 
'Evaluate Merchant Product Range' option. 

• To evaluate Actinic Designer select the 'Evaluate Web 
Designer/VAR Product Range' option. 

Then select a product to evaluate and click 'Evaluate'. 

You will then see the following screen: 
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This is the 'Content' tab where you can set up the sections and products 
in your store, and also see a preview of the store as you build it. 

Down the left hand side of the program is the 'Content Tree'. This shows 
you the section, products, pages and information items in your store. 
Click on the '+' icons in the tree to expand a branch of the tree. Click on 
any item in the tree to see its details appear in the 'Details' panel to the 
right. The 'Preview' panel might also change to show you how the item 
you have clicked on will look in your online store. 

There are two other main tabs: 

• The 'Design' tab is where you can change the look and feel of 
your store pages. 

• The 'Orders' tab is where you manage and process the orders 
received at the store. 

These are both discussed later. 

You will also see the 'Quick Start Tutorial'. 
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The image shown above is for Actinic Catalog. The quick start tutorial 
looks different in Actinic Business and Actinic Designer. 

The quick start tutorial is a step by step guide to the main features in the 
software. Use the arrows at the top right to navigate through the panel. 

Exercise - Changing Panel Sizes 
This exercise will show you how to change the size of the panels in 
Actinic. 

1. Move your mouse to the bottom of the Preview panel (which 
is displaying the current page preview). 

2. Now move your mouse down slowly into the bottom panel. 
As the cursor crosses into the bottom panel it should change 
to look like this: 

 

3. When that happens, click and drag with your mouse to re-
size the panels. 

4. Now go to 'Window' menu and select 'Restore Initial View 
Layout'.  

 

5. This put the panels back to their original sizes. 

Exercise - Rearranging the Panels in Actinic 
This exercise will completely change the arrangement of the panels 
within Actinic. Whenever you get into difficulty and don't know how to 
fix it, don't forget you can always go to 'Window | Restore Initial 
Window Layout'. 

1. Click on the title bar above the content tree and click and 
hold with the left mouse button. 

2. Drag the mouse to the right-hand edge of the Actinic 
window - as far as it will go. As soon as the outline snaps 
into a vertical column, you can release the mouse. 

The content tree should now be down the right-hand side. 

3. Now click and drag the title bar of the 'Details' panel.  

4. Move the mouse cursor onto the title bar of the 'Page 
Preview' panel. You should a tab shape appear at the bottom 
left of the outline.  
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5. As soon as that happens, release the mouse button. 

6. The Details panel should now appear 'on top of' the Preview 
panel, with tabs at the bottom left to move between the two 
panels. 

More Information - Getting Help With Actinic 
The main Actinic help file can be accessed by going to the 'Help' menu 
and selecting 'Help Topics'. 

 

Use the 'Contents' tab of the help to browse by topic. Alternatively, use 
the 'Index' or the 'Search' to locate key words or phrases. 

In addition, click on the question mark -  - at the top right of the Details 
panel, or any of the windows within Actinic, and then click in a field. 
You will be shown a little piece of help about the field. 



10  ••••  Getting Started Getting Started Guide 

Previewing 
Each separate section (and each brochure page) in the store will 
eventually become a single web page in your online store. 

The Preview panel shows you what the page you have selected in the 
content tree will look like online. If you are finding the panel too small, 
or you would like experience more of how your customers will see the 
site, you can always do a preview. This allows you to check out your 
store design in a web browser.  

There are two ways to preview 

• Page Preview - Opens only the current page in a web browser. 
To do this, click the  button on the toolbar, go to 'Web | 
Offline Page Preview' or press [Ctrl + A] on your keyboard. 

• Full Site Preview - Previews all the brochure pages and section 
pages in your store, showing you how it all fits together. To do 
this, click the  button on the toolbar, go to 'Web | Offline 
Preview' or press [Ctrl + W] on your keyboard. 

Exercise - Previewing 
This exercise will step you through the two different kinds of 
previewing. 

1. Make sure you are on the Content tab. 

2. Click on any section (or brochure page) in the store and click 
the  button on the toolbar. Make sure you click the one 
with the single page on the icon and not the double page. 

3. This will display your page in your normal web browser. 

 

4. Now go back to Actinic and click the   button on the 
toolbar. 

5. Navigate through the sections in your store (using the links 
provided) to view them. 
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6. Try adding something to the cart. You should get a warning 
message. This is because you cannot test store functionality 
with a preview - only store appearance. 

Exercise - Previewing Other Pages 
This exercise will show you how to preview pages that are not in your 
content tree. 

1. Go to the Design tab. 

2. Locate the 'Select Page Type' drop down just above the 
preview panel on this tab. 

 

3. Select a page other than 'Content Page'. The page you select 
will appear in the preview panel.  

4. You can then click the  button to see how this page will 
look in a web browser. 

If you are previewing a shopping cart or checkout page within a preview 
page, it will contain some example data. 

More Information - The Design Tab 
The preview panel on the Design tab is different from the one on the 
Content tab as it is interactive. You can click on something in the 
preview, and the HTML code for that item will appear in the 'Layout 
Code' panel at the bottom of the tab.  

For more information about using the Design tab, please see the chapter 
called "The Design Tab" on page 66. 
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Products 
The whole of Actinic is effectively geared around the presentation and 
promotion of your products. Consequently there are many options 
within Actinic that change how your products look and work. With 
Actinic you can (among other thing): 

• Enter a stock level for a product. 

• Create an extended information window, containing a larger 
image and/or a longer description. 

• Set whether the product price is shown including or excluding 
tax. 

• Set whether a downloadable file will be available to customers 
who buy a product. 

• Set up a list of related items that will appear underneath a 
product. 

• and many more...  

Within the content tree products look like this:  

If there is a '+' next to the product, it is because that product contains 
options such as 'size' or 'colour' etc. 

Try clicking on some of the example products that are in Actinic, and 
look at the tabs in the Details panel to see the sort of things you can 
configure on a product. 

Don't forget you can get information about a setting by clicking on the  
at the right of the Details panel title bar and then clicking in a setting. 

Exercise - Adding a New Product 
1. Right-click on the 'Homeware' section in the content tree. 

2. On the right-click menu, select 'New Product'. 

 

3. In the 'Short Description' field, enter 'Running Shoes'. 

4. In the 'Price' field, enter '50.00'. 

5. In the 'Full Description' field enter 'Pair of lightweight 
running shoes'. 

6. In the 'Image' field click 'Browse'. You need to be in the 'Site1' 
folder. If you are not there, browse to the 'Actinic 
v8\Sites\Site1' folder on your PC.  
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7. Select 'x-sneakers.jpg' from the 'Site1' folder. 

 

8. Switch to the 'Layout' tab and change the 'Price Layout' to 
'Standard Tax Inclusive Price'. 

9. Click the 'Apply Changes' button. 

Your new product will appear in the content tree and also in the preview 
panel. 

Exercise - Formatting Text 
This exercise will show you how to change the appearance of the text in 
your product description. 

1. Highlight the text 'running shoes' within the 'Full 
Description' field of your new product. 

2. Press the  button on the toolbar at the top of the details 
panel. 

3. Click 'Apply Changes'. 

4. This will make the text 'running shoes' appear bold in the 
preview. 

Feel free to experiment with the other text formatting options on the 
toolbar to see what effect they have. 

Exercise - Extended Information Windows 
This exercise will add an extended information window to your 'running 
shoes' product. 

1. Switch to the 'Extended Information' tab. 

2. Select 'Generate Pop Up Page'. 

3. In the 'Image' field, just select 'x-sneakers.jpg' again. 

4. In the 'Text' field enter 'This is a longer description for the 
running shoes'.  

5. Under 'Display By', click 'Text Link'. In the 'Link Text' field 
type 'More Info...'. 

6. Click 'Apply Changes'. 

This change has created an additional 'extended information' page that 
will be opened in a pop-up window when you click the 'More Info' text 
on your running shoes product in the preview. 

In order to see the effect this change has made, you will need to: 
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7. Do a full store preview by clicking the  button on the 
toolbar. 

8. Then browse to your running shoes, which are currently in 
the 'Homeware' section. 

9. When you get there, click the 'More Info...' link. 

 

More Information - Other Product Settings 
If you want to ask a general question when people buy this product, then 
enter the question within the 'Other Info' field on the 'Prompts' tab. You 
can also add a date-related question here such as 'When would you like 
the flowers delivered?'. 

 

Use the 'Product Layout' field in the 'Layout' tab to try alternative layouts 
for this product. If you want a more compact layout, try the 'No Image 
No Description Laid Out In Single Line' layout. Feel free to experiment 
with the different layouts there to see the effect they have. Change it back 
to 'Use Parent' if you want to put it back to the way it was. 

There is more information on choosing layouts in “Choosing Alternative 
Layouts” on page 62. 

It is also possible to import a whole load of products in one go from a 
spreadsheet with an 'Import'. This is described in the main help in the 
section called 'Importing'.   
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Sections 
You can use sections to organise your products into separate pages - a 
section becomes a web page in the online store. You can create sections 
within other sections to create a store hierarchy - and Actinic will 
automatically create a link from one section to another. 

Exercise - Adding a New Section 
This exercise will add a new section to the store, and place your new 
'Running Shoes' product within it. 

1. Right-click on the 'Clothing' section and select 'New Section'. 

 

Note: If you select 'New Sub-Section', it creates the section within the 
current section. 

2. Enter a name of 'Sportswear' and a description of 'A great 
range of sports clothes'.  

3. Click 'Apply Changes'. 

 

Your new section has been created in the content tree. The description is 
used in the link to the section on the store front page (visible by clicking 
on the green 'Online Catalog' icon in the content tree).  

You are now going to drag and drop your 'Running Shoes' product into 
the new 'Sportswear' section. 

4. In the content tree click on the 'Running Shoes' product and 
hold the mouse button down. 

5. Keeping the mouse button held down, drag the mouse 
cursor into the 'Sportswear' section.  

6. Release the mouse button. The running shoes product should 
now be in the 'Sportswear' section. 
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Exercise - Optimising A Section 
This section will show you how to use the 'Shopping Mode' feature - 
which controls how products in a section behave when they are added to 
the shopping cart.  

You will also see a few search-engine optimisation features. 

1. Go to your 'Sportswear' section and go to the 'Page Settings' 
tab. 

2. Change the 'Page Name' field to 'sports-clothing.html' (all 
lower case). 

3. In the 'Page Title' field enter 'Sportswear: Sports clothing, 
tracksuits, running shoes'. 

4. Click 'Apply Changes'. 

These two changes will help your page to be more visible to search 
engines. 

The next change will remove the 'Quantity' field from the HTML page. 

5. Under 'Shopping Mode' (on this tab) de-select the 'Use 
Parent Settings' checkbox and select 'Quantity in Shopping 
Cart'. 

6. Click 'Apply Changes'. 

 

Online customers will now enter the quantity of products their require 
once they have added product to the shopping cart. 
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Product Options 
There are many different ways to add options to a product. Here are 
some examples: 

• A simple range of colour options 

• A range of colour options where each colour is individually 
stock monitored 

• A range of size and colour options 

• An extra add-on that costs extra 

• A range of options where each choice costs a different 
amount 

All the above are possible with Actinic, although it is not possible to 
demonstrate them all in this guide. Options are created using the 
following elements in the content tree: 

• Attributes -  - These are characteristics of a product that 
can vary such as 'style', 'length', 'size', etc. 

• Choices -  - These are individual options within an 
attribute. 

• Components -  - These allow you to create more 
sophisticated options such as an optional extra (that costs 
money) or a range of options where each option is a different 
price. 

Exercise - Creating Simple Choices 
This exercise will allow you to create a range of simple size choices for 
your running shoes. 

1. Right-click on your running shoes and select 'New Attribute' 

2. Give it a name of 'Size' and click 'Apply Changes'. 

3. Now right-click on your 'Size' attribute and select 'New 
Choice'.  

 

4. Enter a name of '8' and click 'Apply Changes'. 

5. Now repeat this process to create some more choices for '9', 
'10', '11', and '12'. You can use drag and drop to rearrange the 
choices if necessary. 
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By default, choices appear as a drop down list in your store. If you 
wanted to change your choices to radio buttons, you can select an 
alternative layout within the 'Layout' tab of the 'Size' attribute. 

Exercise - Choice-Dependent Pricing 
This exercise will add a new option to the running shoes of 'In-soles'. 
When customers purchase the shoes, they will be able to choose whether 
they want an in-sole or not, and which type they want - with each one 
being a different cost. 

Before you can create the new option, you need to put the 'Size' attribute 
within a component.  

1. Right-click on the 'Size' attribute and select 'Cut'. You will 
put it back in a moment. 

2. Right-click on the 'Running Shoes' product and select 'New 
Component'. 

3. In the 'Name' field enter 'Selection'. 

4. Delete the value in the 'HTML for Name' field. 

5. Click 'Apply Changes' 

6. Right-click on your new 'Selection' component in the content 
tree and select 'Paste'. 

 

Your 'Size' attribute is effectively back to how it was before, but you can 
now add more components to the 'Running Shoes' product. 

7. Right-click on the 'Selection' component and select 'New 
Component'. 

8. Give the component a name of 'In-Soles'. 

9. Select 'Is Optional' and click 'Apply Changes'. 
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10. Right-click on the new 'In-Soles' component and select 'New 
Attribute'.  

11. Give it a name of 'Type'. 

12. Click 'Apply Changes' and create two choices within the 
'Type' attribute called 'Basic' and 'Super'. 

 

13. Go back to the 'In-Soles' component and select 'Include None 
in Attribute Choice List'. 

14. Now switch to the 'Permutations' tab and click 'Fill List'. 

15. In the 'Price' column next to 'Super' enter '5.00' and click 
'Apply Changes'. 

 

16. Now change to the 'Layout' tab of the component and change 
the 'Component Layout' setting to 'Component Layout With 
Selectable Permutations'. 

This layout includes the prices of the permutations within the drop down 
list. 

17. Click 'Apply Changes' to see the effect. 
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More Information - Associated Products 
The 'Product' column in the 'Permutations' grid (and the 'Associated 
Product' fields in the 'General' tab) are used to associate products in the 
store with options. This means you can keep track of the stock levels of 
choices by associating each choice with a stock-monitored product in the 
store. 

You can read more about associated products in the main help in the 
section called 'Product Options'.  
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Brochure Pages 
Brochure pages are optional information pages you can include with 
your store pages such as 'Special Offers', 'Latest News' etc.  

There are two example brochure pages supplied with Actinic - 'Home' 
and 'More Pages'. You will find these at the top of the content tree. In the 
preview, you will see a list of the brochure pages in the sidebar. 

Brochure pages cannot contain products, but they can contain 
'Fragments' - which are information items on a page. Sections can also 
include fragments. 

Exercise - Creating A Brochure Page 
This will create a new 'How To Find Us' page in your store, and include 
an example information item within it. 

1. Right-click on the 'Home' page at the top of the content tree 
and select 'New Brochure Page'. 

2. In the 'Name' field enter 'How To Find Us'. 

3. In the 'Button Image' field click 'Browse' and locate 
'button_brochure_location.gif' in your 'Site1' folder. 

4. In the 'Button Rollover Image' field click 'Browse' and locate 
'button_brochure_location_highlight.gif' in your 'Site1' 
folder. 

These images are not used in the default Actinic store layout, but they 
will be visible in other layouts. 

5. Click 'Apply Changes'. 

 

This has created a new page in the content tree. 

You are now ready to include a fragment into the page. 

1. Right-click on your new 'How To Find Us' page and select 
'New Fragment'.  

2. In the 'Fragment Title' field enter 'How To Find Us'.  

3. In the 'Text' field enter 'Here is how to find our offices....' 

4. Change to the 'Layout' tab and change the 'Fragment Layout' 
to 'Headline Fragment Layout'. 
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5. Click 'Apply Changes'. 

If you have a suitable image to use for e.g. a map then you can always 
select it in the 'Image' field in the 'General' tab. 

More Information - Links 
If you are creating a fragment that refers to a product or a section in the 
store, you can use the 'Links' tab to create a link to that item. Then just 
include [LINK] in the 'Text' field, where you want the link to appear.  
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Uploading Your Store 
In order to really see your store in action, you need to upload it to a 
website. This will publish your website to the internet, and you will be 
able to use the search, shopping cart and checkout functionality, and 
place test orders. 

Exercise - Uploading a Trial Copy of Actinic 
If you are using a trial version of Actinic, which has been pre-configured 
to work with a specific site, it is simple to upload it to the internet. 

1. Press the blue up arrow ( ) on the toolbar (or go to 'Web | 
Update Website'). 

2. You will be prompted to enter a username and password. 

3. If you do not have a username and password then you will 
need to register for one online. 

• Click on the 'To Apply For A New Account' link, and 
follow instructions on the website. 

• Once you have supplied the required information and 
received a username and password, enter the username 
and password into the fields provided in Actinic. 

4. The upload should then continue. 

 

The first time you upload, it will take quite a while as it needs to upload 
the entire site. After that, however, Actinic will only upload the files that 
have changed. 

One the upload is completed, click the  button on the toolbar (or go to 
'Web | Browse Website') to view your store online. 

More Information - Uploading Actinic To Your 
Own Website 
The instructions in this section will be applicable to the majority of web 
sites, but they won't be applicable to all. If you find they don't work for 
your website then you will need to contact your web hosting company. 
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When the Actinic store is uploaded to your web site, all the store files 
(with a few specific exceptions) are uploaded to two folders on your 
website: 

• 'CGI' folder (often called 'cgi-bin') where all the script files 
will be uploaded to in order to run the online search, 
shopping cart and checkout. These files are sometimes 
referred to as 'Perl files'. 

• A folder called 'acatalog', which Actinic will create, that 
contains all your store HTML files and images. 

Note: The 'home' brochure page can be uploaded to the directory level 
above the 'acatalog' folder' by selecting the 'Use as Web Site Home Page' 
box on the 'home' brochure page. 

Before you try uploading your store you need to know: 

• The URL ('http://') address of your CGI folder. 

• Where the CGI folder is located on your web site (as it 
appears when you connect via an FTP program).  

You will also need to know: 

• The URL and the FTP location of the folder on your website 
that you would like Actinic to create the 'acatalog' folder 
within.  

When you have these pieces of information, you can start the 'Web Site 
Configuration Wizard' by going to 'Web | Configure Web Site Details'. 

 

 The Web Site Configuration Wizard will ask you for your username and 
password to connect to your website, and will ask you to confirm the 
locations, and the http addresses, of the folders mentioned above.  

You can often just accept the defaults to achieve a successful upload. 

When the wizard has finished, you can review the settings at any time by 
going to 'Web | Network Setup'. 

From now on, simply click the  button on the toolbar to upload your 
store.  

For more detailed information on uploading, open the main help and go 
to 'Putting Your Store Online'. 
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Running an Online Business 

Business Settings 
'Settings | Business Settings' is where you can enter details about your 
company and how you do business. 

 

You can also set up how you take payments and charge postage, and 
these are discussed in later chapters. 

It is essential to communicate clearly with your customers on the site 
about who you are, where you are based, how long it's going to take to 
fulfil orders etc. This builds trust in your potential customers, and makes 
them feel more comfortable about placing an order with you. It also helps 
set expectations of customers about delivery times etc. to maintain 
customer satisfaction levels. 

Actinic's main way of communicating all this information is via an online 
'Terms and Conditions' page. This is linked to from every page, including 
the checkout, and contains all the information about who you are and 
how you do business. Contact information is also included on the online 
receipt, and all emails and reports generated by Actinic. 
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Exercise - Entering Company Contact Data 
This exercise will show you where to enter your company details into 
Actinic, and also enter information into an online terms and conditions 
page. 

1. Go to 'Settings | Business Settings' or click the  icon on the 
toolbar. Make sure you are on the 'Company/Contact' tab. 

2. In the 'Name' field, enter your company name. 

3. In the 'Address' and 'Post Code' fields, enter your address. 

 

4. In the 'Contact' area at the bottom, enter your name into the 
'Name' field. 

5. You can delete whatever is in the 'Job Title' field - or change 
it to suit your requirements. 

6. Enter a phone number in the 'Phone Number' field and an 
email address in the 'Email Address' field. You can also enter 
a telephone number into the 'Customer Service Number' 
field at the top. 

7. Enter your website address into the 'Web Site Address' field. 

8. Click 'Apply'. 

Now you have entered some company details, you can enter some terms 
and conditions information. 

9. Change to the 'Terms and Conditions' tab. 

10. In the 'Delivery Schedule' tab, change 'We deliver your order 
right away' to 'Where possible, we will always ship orders 
the same day they are received'. 

 

11. Feel free to make any other changes to the text in the tabs. 

You can now check the results in the preview. 

12. Go to 'Web | Offline Preview' or click the  button in the 
toolbar. Make sure you are previewing the whole store and 
not just the current page. 
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13. Click the 'Terms & Conds' button (or 'Terms' or 'Info' or 
whatever it is called in the theme you are using) to check out 
your changes. 

Exercise - Tax 
In 'Business Settings' you also set up how you want to calculate tax at 
your online store. 

1. Go to the 'Company/Contact' tab in 'Business Settings'.  

2. Change the 'Tax 1 Description' field to read 'VAT Number' 
(or equivalent if you charge an alternative type of tax e.g. 
'Sales Tax # '). 

3. In the 'Tax 1 Number' field, enter your company tax 
registration number.  

4. Click 'Apply'. 

Now change to the 'Tax' tab. 

5. On the tax tab click the 'Simple' option at the top of the tab. 

 

This changes tax calculation to 'Simple' mode, where everyone is charged 
the same tax, no matter who they are or where they are ordering from. 

6. Now change back to 'Advanced' mode. 

'Advanced' mode is where tax is charged according to where customers 
are ordering from. 

You usually do not have to change a great deal here. If you want to 
change the standard tax rate being charged do the following: 

7. Locate the 'Tax Rates' grid at the top right of the tab. 

8. Change the value in the 'Rate' field to the rate you want to 
use. 

To find out more about configuring tax, look at the chapter called 'Setting 
Up Tax', within the 'Business Settings' section in the main help. 

More Information - Advice On Selling 
The key thing to realise about selling online is that the most important 
aspect of it is how you communicate with your customers - both on the 
site as they customers are browsing, and also after the order has been 
placed. A lack of postal address for your company, or unclear 
information about delivery times will lose you more orders than a design 
element that is slightly out of alignment. So take the time to get your 
terms and conditions right, before getting into the more technical aspects 
of the Actinic store. 
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Taking Payments 
Actinic offers a wide range of options for you to take payment from your 
customers. 

If you have an existing offline business, and already have the ability to 
take credit card numbers, then you may just need a way to take credit 
card numbers securely from your online customers. Actinic offers two 
main options for security that both involve SSL - a method for sending 
information securely over the internet. If you want, you can purchase 
your own 'SSL certificate' for your site, and Actinic will work with it. You 
might want to talk to your web hosting company about this. 
Alternatively, Actinic (and others) offer a 'Shared SSL' service that will 
allow you to take credit card numbers securely for an annual fee without 
needing your own SSL certificate. 

However, if you are a new business you will need a third-party to 
process the payments for you, as well as receive the credit card numbers. 
These companies are known as 'Payment Service Providers' and Actinic 
is integrated with a large number of them. 

Exercise - Changing How You Accept Payment 
This exercise will show you how to add a new basic payment method to 
Actinic, and also show you how to change how Actinic takes credit cards. 

1. Go to 'Business Settings | Payment and Security'. 

2. Click the '+' at the top left of the main grid. 

3. In the new row created select 'Cash On Delivery' in the 
'Payment Method' column. 

 

This has now added 'Cash On Delivery' as a payment method in your 
store. If you want to remove it, right-click on the grid and select 'Delete 
Row'. 

Next, you will make a change that will mean that all customers will be 
required to enter the last three digits on their signature strip when they 
enter their card details at the store. 

1. Highlight 'Credit card details captured for later processing' 
in the grid (it is usually the top one) and click the 'Configure 
Method' button. 

2. In the grid at the bottom, select 'CVV2' for all payment 
methods shown. 
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3. Click 'OK'. 

Exercise - Adding a PSP 
This exercise will add a new Payment Service Provider to the list of 
payment methods offered by the store. 

1. In the 'Payment and Security' tab, click the '+' at the top left 
of the grid and from the list provided in the new row, select 
'WorldPay'. 

You could select any of the PSPs in the list. WorldPay is just used here for 
illustration. 

2. Change the 'Web Site Description' field in the grid to read 
'Online Payment with WorldPay'. This changes what is 
shown to your customers online. 

3. Click the 'Configure Method' button. 

 

This is where you will enter your account information once you have  
registered with the PSP. 

4. Click 'OK'. 

You might now want to remove the PSP from the list of payment 
methods. 

More Information - Finding Out About PSPs 
The Actinic web sites (http://www.actinic.com/ and 
http://www.actinic.co.uk/) contain a list of the payment service 
providers (also known as 'payment gateways') that work with Actinic. It 
is worth shopping around to see who can offer the best deal. Most PSPs 
will take a percentage of the transaction value, but some also offer a fixed 
cost per transaction (worthwhile if you sell a lot of high-value goods). 
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Shipping Charges 
Actinic allows you to charge your customers for shipping their order to 
them. There are two approaches to charging for shipping: 

• Use a simple rate that is easy for customers to understand. 
You could base this on how many products the customer has 
bought, or base it on the value of the order. 

• Use a more sophisticated calculation system that works out 
more precisely what the order will cost to ship, and passes 
that cost onto the customer. 

However you want to charge shipping, Actinic has a range of tools to 
meet your needs. 

Exercise - Adding A Shipping Class 
This exercise will add a new shipping class to the ones offered by your 
store. It will charge a set amount per item ordered. 

1. Go to 'Business Settings' and change to the 'Shipping and 
Handling' tab. 

2. Under 'Calculation Basis' (down the left hand side) change it 
to 'Total Quantity'. 

 

You will always be able to change it back to 'Total Weight' (the default) 
after trying this exercise. 

3. Right-click on the 'UK' shipping zone (in the white box in the 
middle of this tab) and select 'Add Class' and then 'New 
Class'.  

4. In the 'Name' field enter 'Test Rate'. You can leave the 
'Description' field blank. 

5. Click 'OK'. 

6. Now with your 'Test Rate' shipping charge selected go to the 
grid to the right and click the '+' at the top left of the grid. 

7. In the new row created, enter '1' in the 'Quantity' column and 
'0.75' in the 'Cost' column. 
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8. Now click the '+' again and in the new row enter '2' in the 
'Quantity' column' and '1.50' in the 'Cost' column.  

9. Now go to the 'Excess' area below the grid. Select 'Increment 
the highest value in the table' and in the top box enter '0.50' 
and in the bottom box enter '1'.  

These settings you have entered will charge 0.75 for the first product, 
then another 0.75 for the second product, and then 0.50 for each product 
after that. 

Exercise - Exempting Products From Shipping 
Charges 
It is simple to prevent certain products from incurring shipping charges. 

1. Go to 'Business Settings | Shipping and Handling' and set 
the 'Calculation Basis' to 'Total Weight'. It way be set as this 
already. 

2. Select the 'Test Rate' rate in the white area in the middle. 

3. In the grid to the right, click the '+' at the top left to create a 
new row.  

4. Leave the 'Weight' field as '0.00' and the 'Cost' field as '0.00'.  

5. Click 'OK' to close 'Business Settings' and then click on a 
product in the content tree.  

6. In the 'Details' tab of the product enter '0.00' in the 'Weight' 
field at the bottom left.  

 

Now whenever anyone buys this product, Actinic will see the weight as 
being '0' and so it will give it a free shipping charge. 

More Information - Issues Around Shipping 
Whoever you choose to ship your products with, make sure they have a 
clearly detailed procedure for handling lost items, and also for tracking 
parcels. This just means you can deal with any complaints about lost 
orders as quickly and as efficiently as possible. 
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Marketing and Promotion 

Best Sellers and New Products 
'Best Seller Lists' and 'New Products Lists' are list of products that can 
appear on every page (or just on specific pages) to promote certain 
products to your customers. 

Best sellers lists work out the best selling products from the orders that 
have been received, and display them as a list in the store. The best 
selling items in your store are the ones that most people will come to 
your site to buy, so by displaying them prominently in your store you 
will help customers find them more quickly, which will hopefully turn 
into more new orders. 

New products lists are made up of the newest items that have been 
added to the store. It is important to keep displaying your newest 
product lines as this keeps your store content current and up to date and 
hopefully gives customers a reason to keep coming back to your store.  

By default in the example Actinic store there is a new products list in the 
sidebar of every page, and also on the brochure home page.  

Exercise - Adding A Best Sellers List 
This exercise will add a 'Best Sellers' list to your store pages. 

1. Go to 'Marketing | Best Sellers'. 

The list is already enabled, and may already have some products within 
it. 

2. Click 'Generate Now'. 
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This will search through the demo orders that are in Actinic and work 
out the best selling items from that. 

3. Now click 'OK' and check out the site. You should see a best 
seller list in the sidebar of every page, and also one on the 
home page. 

 

4. Now go to 'Marketing | New Product Listing'. 

5. Click 'Generate Now'. The running shoes should be added to 
the grid. 

6. Click 'OK' and you should see the running shoes in the 'New 
Products' list on the sidebar of each page. 

 

Exercise - Changing Where The Lists Appear 
This exercise will allow you to control where the best sellers and new 
products lists appear in the store. 
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1. Go to 'Settings | Site Options' and change to the 'Layout' tab. 

2. Find the 'Best Sellers List' sub-heading at the bottom of the 
grid. 

3. Change the 'Location For Best Sellers List' setting to 'Home 
Page Only'. 

4. Now under 'New Products List' change the 'Location for 
New Products List' setting to 'Sidebar Only'. 

 

5. Click 'OK'. 

You should now have best sellers list appearing on the brochure home 
page and the new products listing appearing in the sidebar of every 
page. 

Note: If you try and change the 'New Products List Layout (For Sidebars)' 
or the 'Best Sellers List Layout (For Sidebars)' it doesn't change anything 
in the default 'Executive' theme, but it will have an effect in other themes. 

More Information - Fixing Items In the List 
If you go to the grid at the bottom of 'Marketing | Best Sellers' or 
'Marketing | New Products Listing' you can click on any item in the list 
and use the drop-down list to manually change it to a different item. 

Using this method it is possible to manually configure the list if there 
certain products you want to promote, or certain products you don't 
want to promote. You can also click the 'Lock' checkbox to fix that 
product in the list and let all the other products auto-generate around it. 
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Related Item Lists and Also Bought Lists 
As well as the best seller lists and the new products lists discussed in the 
preceding chapter, it is also possible to display lists of products 
underneath each product in the store. There are two types of these lists: 

• Related Product lists - where you can configure a list of 
other products that are related to a product, and then display 
them on the online store with a link to the related product. 

• Also Bought lists - (Actinic Business/Designer only) - these 
are automatically worked out by Actinic. Actinic can take a 
product in your store, then look at all the orders that include 
that product, and then look at what else the customers order. 
These then become a 'customers who bought this also 
bought...' list underneath the product. 

As well as appearing underneath products in the store, these lists can 
also appear on the shopping cart page in the online store. That way, 
customers can see some products that are related to the products that 
they already have in their shopping cart. 

Exercise - Creating a Related Products List 
This exercise will include a related products list for the 'Basic T' product 
in your store. 

1. Go to 'Marketing | Related Products'. 

2. Select 'Enabled'. 

3. Click 'OK'. 

4. Now go to the 'Basic T' product (within the 'Clothing' 
section). 

5. Go to the 'Marketing' tab and click the '+' at the top left of the 
'Product Related Products' list. 

6. In the row created, choose 'Premium T' from the drop-down 
list. 

This is an example of how you might use the related products list to 
create an up-sell from one product to another. 

7. Now click the '+' and this time select 'Pair of Sandals' from 
the list. 

 

8. Click 'Apply Changes' and check out your changes in the 
preview. 

Exercise - Also Bought Lists 
Actinic Business/Designer only 
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This exercise will generate 'customers who bought this also bought...' lists 
into your store, and show you how to change the layout of them. 

1. Go to 'Marketing | Also Bought...' 

2. Select 'Enabled' and then select 'Generate Now'. 

 

3. Click 'OK' 

This will generate a list for nearly every product in the default store. 

4. Go back to the 'Marketing' tab for the 'Basic T' product. 

You should see that some products have been automatically added to the 
list. These products will appear in a fairly standard numbered list by 
default, but there is an alternative layout option. 

5. Go to 'Settings | Site Options | Layout'. 

6. Under the 'Product' sub-heading, find the 'Product Also 
Bought Item Layout' setting. 

 

7. Change this setting to 'Mini Also Bought Item' and click 'OK'. 

This should include an image, price and description into the also bought 
list for the 'Basic T'. 

 

The related items list also has an equivalent layout option. 

More Information - Lists in the Shopping Cart 
Once you enable either related item lists or also bought lists you will see 
a list appearing in the online shopping cart underneath the grid of 
products. These lists show the related products and also bought products 
for the product that is currently in the shopping cart. If there is more than 
one product in the shopping cart, then Actinic will merge all the related 
products and also bought products into a single list. 
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Mailing Lists 
Actinic gives you the ability to easily extract your customers' contact 
details out of Actinic. This information can then be imported into 
emailing programs like Microsoft Outlook or GroupMail in order for you 
to mail your customers with promotional material. 

This feature can be found at 'Marketing | Mailing Lists'.  

 

All versions of Actinic allow you to filter your customers' contact details 
based on when they placed orders, and what the status of the order is. 
Actinic Business/Designer customers can go further and filter the list 
based on what products were ordered, where the customer is located and 
how large the order was. With Actinic Business/Designer, you can also 
print mailing list information onto labels and envelopes. 

Exercise - Creating a Mailing List 
This exercise will show you how to build a mailing list based on the three 
example orders that are in the 'Orders' tab in Actinic. 

1. Go to 'Marketing | Mailing Lists'. 

 

2. Under 'Order Status', de-select 'Completed' and select 'Any'. 
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3. In the 'From' field, make sure the date is somewhere before 
May 25th 2006 - as that is when the three example orders 
were created. 

4. Make sure that 'Order Payment Status' is set to 'Any'. 

5. Click the 'Preview List' button. 

 

This shows you the three sets of customer data that are ready to export. 

6. In the 'Filename' field, enter 'export.csv'. 

7. In the 'Format' field, select 'Standard Format'. 

8. Click 'Export List'.  

The file will be created in the 'Actinic v8' folder by default. 

Actinic automatically removes any duplicate records, based on the email 
address supplied with the order. 

Exercise - Advanced Filtering 
Actinic Business/Designer only 

This exercise will show you how to filter the mailing list based on 
whether customers have ordered the 'Knitted Sweater'. 

1. Go to 'Marketing | Mailing Lists' and go to the 'Select 
Products' tab. 

2. Click 'Get Products'. 

3. In the tree, click the '+' next to 'Online Catalogue'. Then click 
the '+' next to 'Clothing'. 

4. Select the 'Knitted Sweater' checkbox. 

 

5. Now go back to the 'Main' tab and make sure that the 'From' 
field is set to sometime before May 25th 2006. 

6. Finally, press the 'Preview list' button to update the list. It 
should only contain 'Jack Smith'. 

Filtering can also be done on location (in the 'Location Lookup' tab) and 
order size (in the 'Order Details' tab). 
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Order Level Discounts 
Order-level discounts are available in all versions of Actinic, including 
Actinic Catalog. They allow you to create discounts in the store that are 
triggered by how much the customer has spent online. For example, you 
can use this to create a discount that says "10% off all orders" or "£10 off 
all orders over £75".  

Exercise - Creating a Discount Based on Order 
Value 
This exercise will create a 'weekend sale' where all orders have 10% off 
within a set time period. 

1. Go to the 'Marketing' menu and then select 'Discounts and 
Surcharges Settings...'. 

2. Go to the 'Order Level' tab (if you are not on it already). 

3. Click the 'New' button at the right and enter a name for your 
discount of 'Weekend Sale'. 

 

4. Change the 'Based On' field to 'Cart Value Including Default 
Tax'. 

5. Change 'Type' to 'Percentage'. 

6. In the 'Triggers' grid click the '+' at the top left and enter a 
value of '10' in the 'Percentage' field. 

7. Click 'Apply'. 

 

This will put a discount on your store right away, so before you upload 
and test this, you are going to restrict the discount to only being for this 
weekend. 
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8. Change to the 'Restrictions' tab (within the 'Order Level' tab). 

9. In the 'From' field select the upcoming Saturday. 

10. In the 'To' field select the upcoming Sunday. 

 

11. Click 'OK' 

There will now be a 10% discount on all orders placed at your store for 
the coming weekend. 

Note: you may want to remove this discount if you are about to put your 
store live! 

Exercise - Credit Card Surcharges 
This exercise will apply a surcharge to your store if a customer chooses to 
pay via debit or credit card. 

1. Go to 'Marketing | Discounts and Surcharges Settings | 
Order Level' 

2. Select the 'Credit Card Surcharge Example' discount that 
should already be in the list. 

3. Make sure you are on the 'General' tab. 

4. Select the 'Enabled' checkbox. 

5. In the 'Triggers' grid, change the 'Percentage' value from '2.0' 
to '1.5'. 

 

Notice that the 'Surcharge' box is selected. This means that the percentage 
value here will be added to the order value. 

6. Now change to the 'Restrictions' tab. 

7. Notice that the 'Restricted to Payment Method' box is 
selected, and the list contains 'Credit card details captured 
for later processing'. 
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If you wanted to select a different payment method (such as a PSP) you 
can select an alternative one in the drop down list in the grid 

8. Click 'OK'. 

You can now upload the store to test what effect this discount has online. 

More Information - Restricting Discounts 
In the exercise above you restricted a discount to a date range. You don't 
have to set both the 'For' and 'To' fields - you can set one or the other if 
you want to start a discount now and end it on a certain date, or start a 
discount on a certain date and let it run indefinitely. 

Additionally, if you are using Actinic Business/Designer, you will see in 
the 'Restrictions' tab there is also a 'Restricted to Customer Group' grid. If 
you wanted a discount only for your retail customers or for specific 
customer groups you can use the grid to set it up. 

Customer groups are discussed in a later chapter. 
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Advanced Discounting 
Actinic Business/Designer Only 

As well as creating discounts based on order value, Actinic Business and 
Actinic Designer allow you to create discounts that are based on the 
items that are in the shopping cart. This allows you to set up discounts 
such as '3 for the price of 2' and 'Buy any three books for 5.00'. 

There is an example '3 for the price of 2' discount already set up in the 
'Cart Contents' tab in 'Marketing | Discounts and Surcharges Settings'. 

Also, you have the option to activate any of the discounts by customers 
entering a specific coupon code online. 

Exercise - Buy Both T-Shirts for 10.00 
This exercise will create a new 'Fixed Price' discount for the two t-shirt 
products that are in the default database. The first thing you need to do is 
tell Actinic that the two t-shirts are related to each other. This is done by 
putting them both into a 'Product Group'. 

1. Go to the 'Marketing' menu and select 'Product Groups'. 

2. Click 'New' and enter a name of 'T-Shirts'. 

3. Select the 'Basic T' product from the right-hand list and use 
the '<' button to move it to the 'Members' list. 

4. Do the same for the 'Premium T'. 

 

5. Click the 'Discounts' button and click 'OK' on the message 
that appears. 

You should now be on the 'Cart Contents' tab within 'Discounts and 
Surcharges Settings'. 

6. Click 'New' and enter a discount name of 'T-Shirt Offer'. 

7. Change 'Based On' to 'Quantity'. 

8. In the 'Trigger' field, enter '2'. 
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9. Change 'Product Group' to 'T-Shirts'. 

10. Change 'Reward Type' to 'Fixed Price'. 

11. In the 'Reward Amount' field enter '10.00'. 

 

12. Click 'Apply'. 

13. Change to the 'Presentation' tab. 

14. Enter the following text: 'Buy both t-shirts together for only 
10.00'. 

15. Click 'OK'. 

The 'Buy both t-shirts together...' message will appear underneath the 
descriptions of both t-shirt products in the preview, and will also appear 
in the shopping cart.  

Exercise - Coupons 
This exercise will set up a discount that is only triggered when customers 
enter a coupon code online. 

1. Go to the 'Order Level' tab within 'Marketing | Discounts 
and Surcharges Settings'. 

2. Highlight the 'Weekend Sale' discount you created in the last 
chapter. 

If you don't have this discount set up, then highlight the 'Order 
Adjustment Example' discount that is provided with the default database 
and select 'Enabled'. 

3. Select the 'Requires Coupon Code' box. 

4. Enter a coupon code of '12345'. 

5. Click 'Apply'. 

6. Now change to the 'Miscellaneous' tab. 

7. Under 'Coupon Codes' select 'Store Pages'. 

8. Click 'OK' 

 

This should insert a coupon entry field into the sidebar of your store 
design.  
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More Information - Offering Products as 
Rewards 
One of the 'Reward Type' options you have in the 'Cart Contents' tab of 
'Discounts and Surcharges Settings' is 'Money off extra product' and '% 
off extra product'. These allow you to offer customers free/cheaper 
product as part of a promotion. 

The 'extra product' in question is any product from a specific product 
group that you have set up in Actinic. If you want just to offer a specific 
single product then you will need to create a product group that just 
contains that one single product. 
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Day to Day Administration 

Retrieving Orders 
To retrieve any orders placed at the store, click the green down arrow 
( ) on the Actinic toolbar, or go to 'Operations | Retrieve Orders'. 
Actinic will connect to your store and see if there are any orders on the 
site waiting to be retrieved. It then downloads them and lists the orders 
within the 'Orders' tab. You can view the details of an order by double-
clicking on it. 

Some people check for new orders two or three times a day (or more). If 
you are not expecting that many orders to be placed at your store, you 
can just check your email inbox for 'New Catalog Order Received' 
notification emails. This email is sent just after the first order is placed 
after the most recent order download. You will then know there is at 
least one order to download. 

Note: You must select the 'Send me an Email When I Have an Order to 
Download' checkbox in 'Business Settings | Ordering' to have this email 
sent to you. 

Exercise - Downloading and Viewing Orders 
This exercise will show you how to download and view order details 
with Actinic. You need to have placed some test orders on the site in 
order to have anything to download.  

1. Once you have placed one or more test orders at your Actinic 
store, switch to the 'Orders' tab. 

2. Click the green down arrow ( ) on the toolbar. 

3. Your order should then be listed in the list on the 'Orders' 
tab. 

 

Note: There are three demonstration orders already in Actinic. 
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4. Double click on your new order to open it. 

 

5. The 'Customer' tab shows you the name and address 
information supplied with the order. 

6. Change to the 'Line Items' tab. This shows you the items that 
have been ordered. 

7. Change to the 'Progress and Payments' tab. This shows you 
the payment information entered at the store. 

8. Now click the 'OK' button to close the order. 

In the next chapter you will see how to process an order. 

Exercise - Creating a Packing List 
When you receive new orders, you can print a 'packing list' for each 
order, which can be used when making up the order, and also can be 
used as a delivery note on the front of the package sent. This exercise will 
show you how to print packing lists. 

1. Go to 'Operations | Report Selection'. 

2. Change to the 'Order Processing' tab. 

 

3. Select 'Outstanding Packing Lists'. 

4. Click 'Preview'. 
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This will lay out the order information within a packing list report. 

 

More Information - Assurances 
Orders are encrypted to two levels on the site. Any credit card 
information is encrypted with a 1024-bit encryption key - which you can 
view by going to 'Housekeeping | Security'. The name and address 
information is then encrypted as well, but with a lighter level of 
encryption as that information is less critical. 

Orders are stored as files on the website with an extension of *.ord. Once 
the order is fully downloaded into Actinic, Actinic will send up a 
command to the web site to delete the order files on the site. This only 
happens once Actinic is sure the order has been safely received. 
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Processing An Order 
There is a set of order processing tools built into Actinic. Some are 
optional, and some are required - i.e. Actinic will not consider an order as 
being 'complete' until you carry them out. The required order processing 
steps are: 

• The lines of the order must all be marked as 'shipped' or 
'cancelled'. This is shown below. 

• All payments for the order must be marked as being 
'received'. This is shown below. If you are using a PSP 
(Payment Service Provider) the payment will be taken online 
and so the payments will be marked as received as soon as 
the orders are retrieved into Actinic. 

• An invoice must be printed for the order. 

Alternatively if you don't want to process orders within Actinic then you 
can select the 'Bypass Catalog Order Processing' option in 'Business 
Settings | Order Processing'. 

 

This will mark the order lines as shipped and the payments as received 
as soon as the orders are retrieved. You can then do one of the following 
actions: 

• Print a 'Data Entry' report. This is a single piece of paper 
containing every piece of information about an order. To 
enable this feature, you need to select 'Enable Data Entry 
Reports' in 'Business Settings | Order Processing'. To print a 
data entry report, select 'Outstanding Data Entry Reports' in 
the 'Order Processing' tab of the 'Operations | Report 
Selection' window.  

• Export orders. This exports order information as a set of csv 
spreadsheet files for importing into another application. This 
is typically done in conjunction with 'Actinic Link' - Actinic's 
accounts integration package (Actinic Business/Designer 
only). To enable exports, select 'Enable Export to Files' in 
'Business Settings | Order Processing'. To carry out an 
export, go to 'Operations | Outstanding Exports'. 

Exercise - Processing an Order 
This exercise will show you how to use Actinic's in-built tools to 
complete a new order. This exercise is based around order number 
'DEMO0000000001' in the example Actinic database, but you could easily 
carry out these steps with any order. 

1. Change to the 'Orders' tab (if you are not there already). 

2. Double-click on order number 'DEMO0000000001' in the list. 

3. Change to the 'Line Items' tab. 

4. Highlight 'Great Expectations' and click the 'Ship' button. 
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If the 'Ship' button is not available, it might be because you have selected 
'Bypass Catalog Order Processing' in 'Business Settings | Order 
Processing'. 

5. Highlight 'Pair of Casual Shoes' and click the 'Ship' button. 

6. Highlight 'Teapot' and click the 'Ship' button. 

Obviously if you have different order contents, then ship whatever order 
lines are in the tab. 

7. Click the 'Mail' button. This will generate an 'Order Shipped' 
email ready to be sent to the customer. 

 

8. Click 'Done'. 

You can view the email in the 'Mail' tab of the order. And send it by 
going to 'Operations | Send Mails'. 

9. Change to the 'Progress and Payments' tab, and click 'OK' on 
the warning message that appears (you might want to select 
the 'Don't show this message again' box).  

10. On the 'Progress and Payments' tab you should see the 
demonstration credit card details. Click the 'View Payments' 
button. 

11. Click 'New Entry' and then click 'OK'. 
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This has made an entry in the payment history of the order saying that 
the credit card payment has been received. You would normally only do 
this once you have put the credit card information through a credit card 
terminal. 

12. Click 'OK' to close the order. 

13. Go to 'Operations | Report Selection' and make sure you are 
on the 'Order Processing' tab. 

14. Select 'Outstanding Invoices' and click 'Print'.  

15. This will print the invoice to your printer. 

The order should now have disappeared from the 'Orders' tab. You will 
find it by going to the 'Completed' tab (change tabs at the bottom of the 
window). The order is now marked as completed. 

Exercise - One-Click Order Processing 
Rather than doing each step of the above exercise, it is possible to pre-
configure the things you want Actinic to do to each order, and then 
simply 'Complete' the orders with a single click. This is described below. 

1. Go to 'Business Settings | Order Processing'. 

2. Select 'Enable One-Click Order Completion' (if it is not 
selected already). 

3. Select 'Print Packing List'. 

4. Select 'Mark Packing List Printed'. 

 

5. Click 'OK'. 

6. Now right-click on any order in the 'Pending' tab and select 
'Complete Order'. Or highlight an order and click the 
'Complete' button.  
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The order should move to the 'Completed' tab. 

More Information - Full Order Details 
All the tabs within an order are described below: 

• Customer - This is where you can view and edit the 
customer contact information. 

• Line Items - Use this tab to ship items, and cancel them. You 
can also click the 'Add New Item' button to add a new 
product to the order.  

• Shipping and Handling - You would only really use this if 
you want to change the selected shipping method after 
receiving the order. Change the shipping class in the 'Class' 
field at the bottom right, and then click 'Update Order 
Shipping'. You can also manually enter a shipping charge 
into the 'Calculated' field. 

• Taxes - View the tax charges incurred by the order.  

• Totals - For reviewing any changes you have made to the 
order  

• Progress and Payments - Where you can view the order 
status and enter/edit payment information. 

• Misc. - This is where you can check any supplementary 
information provided with the order such as purchase order 
number, or answers to the 'General Information' questions in 
the checkout. 

• Mail - View the emails generated regarding this order. You 
can also send any pending emails, and generate new ones. 

• Journal - For making notes about the order. 
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Monitoring Stock 
Actinic includes a 'stock monitoring' feature that helps you keep track of 
the stock level of the products in your store. Stock levels are reduced 
when an order for that product is downloaded into Actinic.  

You can enter stock levels for products by going to the 'Stock' tab of a 
product and filling in the 'Estimated Stock In Hand' field. You will also 
need to make sure the 'Stock Monitoring' checkbox is enabled. 

 

You can also get an overview of the stock levels of all the products in 
your store by going to 'Operations | Stock Levels' or by clicking the  
icon on the toolbar. This allows you to quickly add/review stock levels in 
Actinic across a number of products. 

 

There are two stock warning levels for Actinic: 

• Warn If Below - if the stock level of a product falls below 
this level, you will receive a warning when you download 
orders. 

• Suspend If Below - if the stock level of a product falls below 
this level then the add to cart button will be replaced with an 
'OUT OF STOCK' message. 

You can set default values for these two stock warning levels in 'Business 
Settings | Options'. 

 

By default, none of the products in the example store are stock 
monitored. 

Exercise - Stock Monitoring 
This will simulate what happens when a product goes out of stock. 



Getting Started Guide Day to Day Administration  ••••  53 

1. Go to your 'Running Shoes' product you created earlier. 

If you don't have this product, you can use any product. 

2. Switch to the 'Stock' tab. 

3. Set the stock level at '20'. 

4. Click 'Apply changes'. 

This product is now stock monitored. If you place a test order for this 
product the stock value will go down. 

5. Now change the stock level to '1' and click 'Apply Changes'.  

6. You should find that the add to cart button has been replaced 
with an 'Out Of Stock' message. 

 

7. Now go to 'Operations | Stock Levels'.  

8. Change the 'Select Product Type' drop down to 'Ordering 
Suspended' to see the product you have just put out of stock. 

You would now need to upload the store in order to see the product 
marked as being out of stock online. 

More Information - Stock Reports 
There are a few reports available to help you monitor stock levels in your 
store. If you go to 'Operations | Report Selection' there is a 'Catalog' tab 
that features four 'Stock Level' reports. You can print these to help you 
monitor the stock levels in your store. 
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Entering New Orders 
As well as receiving orders from your online store, Actinic also allows 
you to enter orders straight into the program. This allows you to also 
take orders over the phone or via fax, and keep all the order information 
in one place. 

Exercise - Adding a New Order Into Actinic 
This exercise will show you the basics of entering a new order into 
Actinic. 

1. Go to the 'Orders' tab and go to 'Operations | New Order' (or 
click the 'New Order' button at the bottom of the tab). 

2. On the first screen select 'Shopped Before'. This will save you 
a lot of typing later on. 

3. Click the 'Search' button and then click the 'Search' button on 
the new window. This should give you a list of all the orders 
currently in Actinic. 

4. Select an order and click 'Select'. 

 

5. Click 'Next >' to move to the next screen. 

6. Review the contact information and then click 'Next >'. 

7. This screen is where you add items to the order. Click 'New'. 

8. From the 'Select Product' drop down list select 'Set of 
Glasses'. 

9. In the 'Components/Attributes' window select the '8 Glasses' 
option. 
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10. Click 'OK' and then click 'Next >'. 

11. This screen is where you can select the shipping method and 
enter payment information. Make sure 'Payment Method' is 
set to 'Credit Card' and select 'Type' of 'Visa'. 

12. For the 'Number' enter '1111222233334444'. 

13. Select a valid 'Expiration Date' and click 'Next >'. 

14. Click 'Confirm' to complete the new order. 

Your new order should now be added to the list of orders in the 
'Pending' tab. 

Exercise - Editing An Existing Order 
It is possible to edit an order to add new items. This exercise will show 
you how. 

1. Double-click on an order in the 'Orders' tab. 

2. Change to the 'Line Items' tab. 

3. Click the 'Add New Item' button. 

 

4. Click 'New' and add the 'Far From the Madding Crowd' 
product to the order. Click 'OK'. 

5. Click 'Next >' then click 'Next >' again and then click 
'Confirm' to complete the addition. 

Your new book should now be visible within the 'Line Items' tab. 

More Information - Settings in Business Settings 
If you go to the 'Order Processing' tab within 'Business Settings' you will 
see there are few settings here under the heading of 'Offline Order 
Processing'. 

 

Select 'Allow Unit Price Override' if you want to be able to change the 
price of items while you create new orders. 

You can also choose a different prefix for the offline order numbers in the 
'Order Number Prefix' field. 
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Regular Customers 
Using Actinic, you can set up customer accounts for your regular 
customers. This allows customers to log into the store with a username 
and password, and have their name and address information preset in 
the checkout. 

If you are using Actinic Business/Designer you can go further and group 
your customers into 'Customer Groups'. You can then assign discounts to 
these customer groups and also hide products from certain groups of 
customers. 

Exercise - Creating A Customer Account 
This exercise will show you how to create a basic customer account. 

1. Go to 'Operations | Customer Accounts' or click the  icon 
on the toolbar. 

2. Click 'New Customer'. 

3. In the 'Name' field enter 'Test Account'. 

4. Click the 'Copy Details From Order Contact' button. This 
shows you all the order contact information already in 
Actinic. 

5. Double-click on one of the names in the list. This will 
populate the rest of the fields here - and saves some typing. 

 

6. Change to the 'Addresses' tab. This has been pre-populated 
with the order information brought in by the previous step. 

7. Change to the 'Buyers' tab and click 'New'. 

A 'Buyer' is a customer who will actually log into this account with a 
username and password. 

8. Change the 'Login', 'Password' and 'Confirm' fields all to be 
'a'. This is so you can log into the store quickly to test this. 
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9. Click 'OK'. 

Your new account has now been created. To test this, upload the store 
and click the 'Login' link. Then enter a username and password of 'a' to 
log into the account. Add something to your cart and checkout to see the 
preset address information. 

 

Exercise - Creating A Customer Group 
Actinic Business/Designer Only 

You will now create a 'Trade' customer group, who will receive a 20% 
discount when they log in.  

1. Go to 'Marketing | Customer Groups' or click the  button 
in the toolbar. 

2. Click 'New' and enter a name of 'Trade'. 

3. Highlight your 'Test Account' account and use the '<' button 
to move it to the left 'Associated Accounts' column. 
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4. Click the 'Customer Pricing' button, and click 'OK' on the 
window that appears. 

5. Highlight 'Trade' in the list and select 'Multiply By'. 

6. In the field enter '0.8' and click 'OK'. This will give a 20% 
discount. 

 

Now upload the store and log in to test the discount for 'Trade' 
customers. You should see both a 'Retail Price' and a 'Your Price' 
appearing in the store. 

More Information - Sophisticated Buyer Options 
Go back to the 'Test Account' account in Actinic and look at the 'Buyers' 
tab. There are quite a few useful options here: 

• Select 'Hide Retail Prices' if you only ever want this buyer to 
see a single price (rather than 'Your Price' and 'Retail Price'). 

• Select 'Allow User to Select or Enter a New Address' if you 
want to allow your customers to enter their own new 
addresses into the store, as well as using a saved address 
online. 

• You can enter a 'Maximum Order Value' for this buyer if you 
want to limit the amount they can spend on an order. 
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Designing Your Store 

Please note that the following features are not available in 'Client' 
versions of Actinic. 

Choosing A Theme 
A theme is a quick way to assign a new look and feel to your store. It is 
worth experimenting with the themes that are available so you can find 
one you like - and then use that as a starting point for any further 
customisations. 

Exercise - Changing Theme and Colour Scheme 
This exercise will just use simple settings to change the look and feel of 
your store. 

1. Go to 'Design | Themes'. 

2. In the 'Themes' list, change it to 'Technical'. 

3. In the 'Color' list, change it to 'Cool Red'. 
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4. Click 'OK'. 

 

This has now applied a new look and feel to your store, but you can 
change each individual element at a much more granular level. 

Exercise - Changing Different Elements of a 
Design 
This will show you how to change the default product layout for your 
entire store, and also show you how the 'Advanced Themes 
Configuration' works. 

1. Go to 'Settings | Site Options'. 

2. Go to the 'Layout' tab. 

3. Under the 'Product' sub-heading, find the 'Product Layout' 
setting. 

4. Change it to read 'Standard With Image On Left'. 

 

5. Click 'OK'. 

You should now find that your products have changed appearance 
slightly. 

6. Go back to 'Design | Themes' and click 'Advanced Themes 
Configuration'. 

7. Change to the 'Buttons' tab and select 'Basic Coloured 
Buttons'. 
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8. Click 'OK'.  

Your add to cart buttons should now look different. 
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Choosing Alternative Layouts 
It is possible to select different layouts for every single item you see in 
the content tree. This is done by going to the 'Layout' tab of the item in 
question, and selecting an alternative layout. 

Very often a setting will have the words 'Use Parent' in it. 

 

'Use Parent' simply means that the value for this setting is set somewhere 
'higher' up the Actinic structure, and the value is inherited down the 
store structure. If you click on a setting it will usually tell you where the 
value has been set in the area underneath the grid of settings. 

 

When the value is coming from 'Settings | Site Options', you can edit it 
by going to 'Settings | Site Options' and then go to the 'Layout' tab. 

When it says the value is coming from the 'Variable Definition' you can 
still change the value by going to 'Settings | Site Options | Layout' - it 
just means that the value has been set in the default Actinic program 
settings. 

Exercise - Changing Layouts 
This exercise will show you a selection of changes you can make within 
Actinic. To begin with, you will change the way section links appear. 

1. Go to 'Settings | Site Options' and change to the 'Layout' tab. 

 

2. Under the 'Section' sub-heading, locate the 'Section Link 
Layout' field. 

3. Change the layout to 'Section Name Only Section Link'. 

4. Click 'OK'. 
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To best see the effect of the new section link layout, click on the green 
'Online Catalogue' icon in the content tree. 

 

Next, you will change the way all the prices appear in the store. You will 
change Actinic to show prices including tax. 

1. Go back to 'Settings | Site Options | Layout'.  

2. Under the 'Product' sub-heading, locate the 'Price Layout' 
field.  

3. Change this to read 'Standard Tax Inclusive Price'. 

4. Click 'OK'. 

Look at your products to see the effect. Your product prices are now 
shown including tax. 

 

Now, you will change the layout of a specific product in the store. 

1. Go to the 'Starter Computer Bundle' product in the 
'Computers' section. 

2. Go to the 'Layout' tab. 

3. Change the 'Product Layout' to be 'Standard With Image On 
Right'.  

The 'Starter Computer Bundle' now looks different from the other 
product in the section. 

 

Finally, you will change the layout of the choices for the running shoes. 

1. Go to the 'Running Shoes' product within the 'Sportswear' 
section  

This was created in the exercises at the beginning of this guide. If you 
don't have this product, then use the 'Basic T' product within the 
'Clothing' section. 

2. Click on the 'Size' attribute and go to the 'Layout' tab. 

3. Change the 'Attribute Layout' to 'Standard Radio Button 
Attribute'. 
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4. Change the 'Column Count For Radio Buttons' to '2'. 

5. Click 'Apply Changes' to see the results. 

 

Feel free to experiment with any of the settings in the 'Layout' tabs within 
Actinic to see the effect. 

Exercise - Further Layout Changes 
Here are some examples of further layout changes you can make in the 
'Layout' tabs in Actinic. To begin with, you will change the look and feel 
of the main area of one of the sections in the store. 

1. Go to the 'Clothing' section in the store and go to the 'Layout' 
tab. 

2. Under the 'Section' sub heading, change the 'Main Product 
Area Layout' setting to be 'Standard Section Page'. 

3. Click 'Apply Changes'. 

This gives a different look and feel to this section. 

 

Next, you will put the products in the store into two columns. 

4. Go to 'Settings | Site Options | Layout'. 

5. Under the 'Product' sub-heading, locate the 'Column Count 
For Products' setting. 

6. Change this to '2' and click 'OK'. 

This puts your products into two columns on the page. 
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You may want to experiment with different product layouts to see which 
one works best in this configuration. 

Finally, you are going to change the layout of the section list that appears 
on the front page of the store. 

7. Go to 'Settings | Site Options | Layout'. 

8. Under the 'Section' sub-heading, locate the 'Top Sub Section 
List Layout' setting. 

9. Change this to read 'Standard Sub Section List' 

 

10. Click 'OK'. 

Now click on the green 'Online Catalogue' icon in the content tree to go 
to the store front page. The horizontal lines should be gone from the list 
of sections. 

 

More Information - Layout Selectors 
The layout selection drop-down lists in Actinic are all controlled by 
things called 'Layout Selectors'. It is possible to edit the layout selectors in 
Actinic to change the order of layouts in the drop-down list, remove 
layouts and even add your own custom layouts.  

This is described later on in “Adding New Layouts to Actinic” on page 
79. 



66  ••••  Designing Your Store Getting Started Guide 

The Design Tab 
The 'Design' tab is used to change the look and feel of specific elements of 
your page design. 

 

It is divided into three main areas: 

• Interactive Preview - Click on anything in the preview and a 
dotted line will appear around it. If a piece of text is selected, 
you will be able to change the appearance of it with the 
formatting controls in the toolbar above the interactive 
preview. Also, the HTML  that lays out the part of the page 
you have selected will appear in the 'Layout Code' panel at 
the bottom. 

• Layout Code - This shows you the code of whatever you 
have clicked on in the preview. You can edit the code here 
and click 'Apply' to see the effect on the preview. At the 
bottom of this panel are two tabs where you can change 
between the 'Layout Code' tab and the 'Details' tab (where 
you can edit names, descriptions, etc.) 

• The Content Tree/Design Tree Panel - Down the right-hand 
side of the Design tab is a narrow vertical panel that either 
contains the Content Tree or the 'Design Tree' - depending 
on what tab is chosen at the bottom of the panel. The Content 
Tree allows you to quickly change the section you are 
viewing in the Design tab. The Design Tree shows you all the 
layouts that make up the current page. 

If you want to select a section to edit, use the Content Tree. If you want to 
edit a page that isn't a section (including email and style sheet layouts) 
then use the 'Select Page Type' drop down at the top left of the Design 
tab. 
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Exercise - Changing Fonts 
This exercise will show you how to use the Design tab to change the 
appearance of the text in your store. 

1. Go to the 'Homeware' section. 

2. Click on the 'Teapot' product name in the preview. 

3. Click on the  icon in the preview toolbar to make the 
product name italicised. 

4. Click on the  icon and then choose an alternative colour for 
the product names. 

You can do this kind of text formatting for any text in the store. 

5. Now click the 'Undo' icon on the toolbar -  

6. This should reverse out the colour change. 

7. Now select a different colour. 

 

Notice that the change you made changed all the products on the page - 
this is because they are all using the same layout. It will also change the 
appearance of products in other sections in your store. 

Exercise - Using Panels 
This exercise will help you understand how the panels on the Design tab 
work. 

1. Make sure you are on the Design tab. 

2. At the bottom right of the tab you should see two tabs called 
'Content Tree' and 'Design Tree'. Click on the 'Content Tree' 
tab to make sure that the content tree is visible. 

  

3. Click on the Running Shoes product in the content tree (or 
click on any other product if you don't have the Running 
Shoes. 
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4. Locate the tabs at the bottom left of the Design tab and click 
on the 'Layout Code' tab to make sure that the layout code is 
visible. 

 

5. In the preview, click on the Running Shoes product name. 
This should highlight a piece of blue text in the layout code 
that says 'ProductName'. 

 

6. Now use the tabs at the bottom left of the Design tab to 
switch to the 'Product Details' tab. 

7. In the 'General' tab, change the short description to read 
'Running Shoes - New!' and click 'Apply changes'. 

8. This should change what appears in the preview. 

 

In other words, this has changed the text which is inserted into the 
design by the variable called 'ProductName'.  

You'll learn more about variables in the next section. 
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Inserting Variables into the Design 
When you are looking at the layout code in the Design tab, as well as 
standard HTML code, you will also see 'variables'. 

A variable is a placeholder for a piece of Actinic data. For example, if you 
click on a product name in the interactive preview, it highlights a 
variable called 'ProductName'. In the layout code they appear in blue. 

 

You can use the 'Insert Variable' toolbar button at the top of the layout 
code panel to add new variables into the design. 

 

Exercise - Adding a Variable Into the Design 
This is a basic exercise that will show you the principle of adding a 
variable into a layout in Actinic. It will add the current section 
description at the top of each section page. 

In order to do this exercise you need to have the name of the section at 
the top of the section. 

If you don't have this, go into a section in your store, and in the 'Layout' 
tab, change the 'Main Product Area' setting to be 'Section Page With 
Section Name At The Top'. 

1. In the preview in the Design tab, click the section name at the 
top of the page. 

 

2. This should highlight a variable called 'SectionName' at the 
top of the section. 

 

3. Add a new blank line after this line. 

4. Put your cursor in the new blank line and click the 'Insert 
Variable' button -  

5. In the 'List Names Containing' box, type 'Section'. 
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6. Locate 'SectionDescription' in the list and click 'Insert'. 

7. Click 'Apply'. 

This has inserted the section description at the top of each section page. 

 

Exercise - Looking Up A Variable 
If you ever need to find out what a variable does, and where you can set 
the value of it, you can use the 'Variable Reference Guide'. This exercise 
will show you how. 

As an example, let's say you needed to find out more about the 
'SectionDescription' variable. 

1. Go to 'Help | Variable Reference Guide'. 

2. Change to the 'Search' tab. 

3. Type 'SectionDescription' and click 'List Topics'. 

4. Double click on the first item in the list. 

This gives you a short description of the variable, and tells you where the 
value of the variable can be set. 

You can also use the 'Contents' tab to browse by product area. 
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More Information - Typing Variable Names 
It is also possible to add a variable into a layout by starting to type the 
variable name into the layout. 

 

After typing three or four letters, a window will appear that shows you 
the possible variables to insert. 
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Creating New Variables 
Actinic allows you to create any number of custom settings for the items 
in your content tree. Examples of this include an 'Artist' field for CDs, a 
'Starring' field for DVDs, or an 'Author' field for books. These custom 
settings are referred to within Actinic as 'User-Definable Variables', and 
they appear within grids like this: 

 

You can then include these custom settings into your store designs by 
inserting the variable into the layouts, as discussed earlier. 

Exercise - Creating a New Variable 
In this exercise you will add a new 'Author' variable within Actinic, and 
then include it into the design. 

1. Go to the Design tab and then make sure you are looking at 
the 'Books' section. 

2. Click on the name of one of the books on this page. This 
should highlight the 'ProductName' variable. 

3. Add in a new blank line straight after the variable. 

4. In the new blank line, type <br /> 

You might notice that Actinic prompts you here to complete the tag. This 
is a feature of Actinic - it will help you create the HTML within the 
layouts. 

5. Just after the <br /> right-click and select 'Insert Variable'. 

 

6. Click the 'New' button on the window that appears. 
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7. In the 'Name' field, enter 'Author'. 

8. In the 'Description' field enter 'New field for the author of the 
books'. 

9. In the 'Prompt' field enter 'Enter Author Name'. 

10. Under 'Place Of Setting' select 'Product'. 

This means that the new field will appear for your products. 

11. De-select 'Allow <Use Parent> as an Option'. 
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12. Click 'OK' and then click 'Insert'. 

13. Click 'Apply'.  

You can now change to the Content tab in Actinic and enter the author 
value in for the three books. You will find the new field within the 
'Properties' tab. 

 

 

If the author value has not appeared for all your books, it may be because 
your books are using different layouts from each other. You may need to 
insert the <br />Author in more than one layout. 

Exercise - Limiting By Content Category 
Go to a product in the 'Clothing' section and look at the 'Properties' tab. 
You'll see that currently, the 'Author' field is appearing for all the 
products in the store. However, you only need it to appear for your 
books. It is possible to limit custom variables to specific products by 
using a feature called 'Content Categories'. 

You are going to create a new 'content category' in your store called 
'Books' and then restrict the 'Author' field to only appear for that content 
category. 

1. Go to 'Design | Content Categories'. 

2. Highlight 'Product'. 
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3. Click 'New' and enter a category name of 'Books'. 

 

4. Click 'OK'. 

5. Go to the 'General' tab of each of your books and change the 
'Category' field to 'Books'. 

 

You are now going to limit the 'Author' field to only appear for this 
books category. 

6. In the Design tab, click on an author name in the preview, 
then right-click on it and select 'Edit Variable'. 

7. Change to the 'Advanced Place Of Setting' tab. 

8. Click the '+' next to 'Product' 

9. De-select 'Standard'. 

 

10. Click 'OK'. 

Your 'Author' setting should no longer appear for the products in your 
store that are not books. To check this, look at a product in the 'Clothing' 
section and check the 'Properties' tab. The 'Author' field should no longer 
be there. 

More Information - Lists of Choices 
When you are creating a new variable, you can change the 'Type' field to 
'List of Choices'. Once you do this, the 'Values' tab becomes activated and 
you can preset a list of choices for this variable.  
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Editing Layouts 
The Layout Code panel within the Design tab can also be used for 
making general HTML changes to your layouts, and also inserting new 
layouts within your layouts. 

Exercise - Making HTML Changes To Layouts 
This exercise will guide you through a basic HTML change to a layout, 
and show you how to change it back to how it was before. 

1. Locate the 'Product Sections' section list that is in the sidebar 
of your page. 

2. Click on the 'Books' link within this list. 

This will open the 'Section Name Only Section Link' layout in the layout 
code panel. The 'SectionName' variable should be highlighted within the 
layout.  

If you cannot see any HTML code, try clicking on the 'Layout Code' tab 
at the  bottom left of the Design tab.  

3. Just after the 'SectionName' variable, add three dots '...' and 
click 'Apply'. 

 

4. You should see the three dots after each section link in the 
preview. 

5. Now replace the '...' with a ' >' and click 'Apply'. 

6. Now click the 'Undo'  ( ) button on the toolbar twice to 
cancel both changes. 

This shows how it is possible to experiment and tweak the layouts in 
Actinic without worrying about not being able to go back. 

Please note though that once you leave the Design tab, or make any 
changes to your product data (such as changing the product name etc.) 
you will not be able to undo your design changes. 

More Information - The Library 
If you go to 'Design | Library' you will see the 'Library'. This is where 
you can manage all the layouts and variables that are in Actinic.  
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• In the 'Layouts' tab of the library, layouts (and layout 
selectors) are all grouped by 'Type' - and the types are sorted 
alphabetically. 

• In the 'Variables' tab of the library you will see all the 
variables in the design that are editable.  

• The 'Conditions' tab is discussed later in “Using Conditions” 
on page 85. 

You can use the library to edit and rename the elements that make up 
your design. 

You can also create new layouts, as discussed in the next chapter. 

More Information - The Design Tree 
Layouts are always inserted into other layouts, which creates a hierarchy 
of layouts within the page. This is what is shown in the Design Tree at 
the left hand side of the Design Tab. It shows you the hierarchy of 
layouts that makes up the page design that you are currently working on. 
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Adding New Layouts to Actinic 
It is simple to add your own new custom layouts to Actinic. This is useful 
if you want to experiment with changing layouts without affecting the 
default layouts that came with Actinic.  

Exercise - Creating a New Product Layout 
This exercise will show you how to add your own custom product layout 
to Actinic.  

1. Change to the 'Content' tab. 

2. Select the 'Running Shoes' product you created earlier. If you 
don't have this product, then you can use any product in the 
store. 

3. Change to the 'Layout' tab and locate the 'Product Layout' 
field.  

4. At the bottom of the 'Product Layout' drop down list you 
should see a <New> option. Select this option. 

 

5. For the name of the new layout enter 'Sale Layout'. 

6. In the 'Based on' field, select 'Standard With Image On Left'. 

7. Click 'OK'. 

8. Make sure 'Sale Layout' is selected in the 'Product Layout' 
field. 

9. Click 'Apply changes'. 

The product won't look any different at the moment. This is because you 
haven't made any changes to the layout yet. You can now switch to the 
Design tab and customise your new 'Sale Layout' layout. 

10. Change to the 'Design' tab. 

11. Use the content tree to select the product you have just been 
editing. 

12. Click on the product name in the interactive preview. 

You should be in the layout called 'Sale Layout' and a variable called 
'ProductName' should be highlighted. 

13. Just after it, type ' - ON SALE'. 

 

14. Click 'Apply' and then click 'OK'. 
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This will include an 'on sale' message to any product that is using the 
'Sale Layout'.  

Exercise - Looking at Layouts in The Library 
This exercise will show you how to find layouts in the Library, and also 
how to change where the new 'Sale Layout' appears in the 'Product 
Layout' drop down list. 

1. Go to 'Design | Library' and change to the 'Layouts' tab. 

2. Right-click anywhere within the library and select 'Find'.  

3. In the 'Search for Text' field, type 'Sale Layout'. 

4. Click 'Find Next Item'. 

This will highlight your new 'Sale Layout' layout. It is within the 
'Products' group. 

 

It is now possible to edit the 'ProductLayout' layout selector - which 
controls the drop down list where you select the product layout. Layout 
selectors have the following icon - . 

You are going to move 'Sale Layout' to the top of the drop down list. 

1. Double-click on the 'ProductLayout' layout selector. 

2. Change to the 'Values' tab. 

3. Highlight 'Sale Layout' and use the arrows to move it to the 
top of the list. 

 

4. Click 'OK'.  

The new 'Sale Layout' layout will now be first in the list of product 
layouts offered by the 'Product Layout' setting. 

5. Go to any product in your store. 
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6. In the 'Layout' tab, change the 'Product Layout' to 'Sale 
Layout'. It should be the first layout in the list. 

7. Click 'Apply changes'.  

More Information - Deleting and Restoring 
Layouts 
If you have created a layout that you no longer want, you can right-click 
on it in the Library and select 'Delete'. If the 'Delete' option is greyed out 
for any reason, this is because the layout is being used somewhere in 
your store, so you need to make sure it isn’t selected in 'Site Options' or 
anywhere in the content tree. 

If you have made a change to one of the layouts that came with Actinic, 
and you want to put the layout back to how it was originally, you can 
right-click on a layout in the library and select 'Revert to Factory 
Settings'. 

 

It is also possible to create new layouts while you are in the library. 
Simply right-click on a layout and select 'New Layout'. 
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Inserting Layouts Into Your Design 
When you are looking at the layout code within Actinic, as well as 
standard HTML code and variables, you will also see things that look 
like this: 

 

These are 'layout selectors' in the design. Layout selectors work like 
variables, but rather than inserting text into a layout, they actually insert 
a layout within the current layout. 

You can use the toolbar button at the top of the layout code panel to add 
new layout selectors into the design. 

 

Exercise - Adding a New Navigation Link 
This exercise will add a new 'Terms and Conditions' link to the store 
navigation bar. 

To do this exercise, you need to be using the 'Technical' theme. Please 
change to this theme if you are not on it already. 

1. In the interactive preview, click on the 'Search' button 
halfway down the list of buttons in the sidebar. 

2. You should now see the code of the 'Search' button in the 
Layout Code panel at the bottom of the Design tab. 

3. Click the 'Navigate To Parent Layout' button -  - in the 
toolbar that is underneath the layout code. This should take 
you to the 'parent layout', which is called 'Works Best With 
Technical'. If it doesn't take you there, try clicking it again. 

 

You are now looking at the layout selector that inserts the 'Search' button 
into the design. 

4. Add in a new blank line underneath the 'Search CSS Large 
Button' layout selector. 

5. Put your cursor in the blank line created and click the 'Insert 
Layout' button on the toolbar -  

6. In the 'List Names Containing' box, enter 'nav'. 

7. From the list at the top of the window, select 
'NavigationIcon'. This is the layout selector you are going to 
insert. 
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You could just insert the layout selector as it is, but this gives you no 
control about the actual layout that will be inserted into the design. 
Instead, you are going to 'fix' the layout so a specific layout will be 
inserted by this layout selector. 

8. Select the 'Use Fixed Layout' box. 

9. From the list of available navigation icon layouts, select 
'Terms CSS Large Button'. The layouts are in alphabetical 
order. 

 

10. Click 'Insert'. 

11. Click 'Apply' to see your new layout in action. 
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More Information - Fixed Layouts 
If you ever want to change the layout that is being inserted by a layout 
selector, simply right click on the layout selector in the code and select 
'Edit Appearance'. You can then select the layout with the 'Use Fixed 
Layout' setting. 

 

When a layout selector isn't using a fixed layout, it generally means the 
layout can be selected within the 'Layout' tab in 'Settings | Site Options', 
or within the 'Layout' tab of a product, or section. In the chapter called 
“Adding New Layouts to Actinic” on page 79 you'll find out how to edit 
the layout selectors in Actinic to change the range of layouts that are 
available for you to select from. 
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Using Conditions 
'Conditions' allow you to show/hide pieces of your layout based on 
settings in Actinic. They allow you to not just change the way Actinic 
looks, but also change the way Actinic works. 

Conditions in Actinic look like this: 

 

The text between the two 'block' tags will only be shown if the condition 
statement is 'true'. You can specify the condition statement using 
variables and rules that control when to display the text. 

If you ever want edit a condition statement, double-click on the opening 
'block' tag. This shows you the condition that must be 'true' in order for 
the text to appear. 

Exercise - Creating A Condition Based On Stock 
Level 
This exercise will include a simple message into the product layout based 
on the stock level of the product. 

1. In the Design tab, select any product layout by clicking on a 
product name. 

2. Scroll to the bottom of the layout code of that product layout 
until you find 'ProductRelatedProductsList'. 

3. Add a blank line just below this line. 

4. Insert a <br /> into this line. 

5. Then enter the following text 'This product is running low on 
stock. Please call us to check availability'. 

 

6. Click 'Apply'. The text should appear for some or all of the 
products on this page. 

7. Now highlight the entire line you entered and click the 
'Insert Block' button on the layout code toolbar -  

8. This will open the 'Expression Editor'. 
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You are going to create a condition that says 'the product is stock 
monitored AND there is less than 10 of them in stock'. 

9. Start typing 'IsStock...'. You should see Actinic prompting 
you to insert a variable. Select 'IsStockMonitored' by pressing 
'Enter' on your keyboard. 

 

10. Now click the 'Insert an operator into expression' button and 
select 'And' from the drop-down list provided. 

 

11. Type a standard left bracket - '(' 

12. Now start typing 'StockLevel'. When Actinic prompts you to 
enter the 'StockLevel' variable into the design, press 'Enter' 
on your keyboard. 

13. From the 'Insert Operator...' list, select 'Less Than'. 

14. Now type '10' (without the quotes) and enter a standard right 
bracket - ')' 

 

15. Click 'OK'. 

16. Click 'Apply' to confirm the changes. 
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Now change to the 'Content' tab to test this change.  

17. Go to any product in the content tree and go to the 'Stock' 
tab. 

18. Select 'Stock Monitoring' and enter an 'Estimated Stock In 
Hand' of '6'.  

19. Click 'Apply changes'. The stock message should be visible 
in the preview. It will be underneath your list of 'also bought' 
products, if you have one displayed. 

. 

20. Now change the 'Estimated Stock In Hand' to '20' and click 
'Apply changes'. 

The stock message should disappear. 

This is a condition based on stock level. You can also create conditions 
that are based on whether or not a setting has been filled in by using the 
'Is Not Empty' operator. For example, the following condition will hide 
code unless the 'Author' field has been filled in. 

 

More Information - Reusable Conditions 
The 'Conditions' tab of the Library is used to store reusable conditions. 
As an example, go to the 'Product' group within the Conditions tab and 
double-click on 'IsAddToCartButtonShown'. 

This shows you all the conditions that must be met in order for the add to 
cart button to appear. You can see where this reusable condition is used 
in the design by double-clicking on the block tags that surround the 
'AddToCartButton' layout selector in your product layouts.  
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Content Lists 
Sometimes a layout needs to be inserted multiple times into a design. For 
example, a product layout needs to be inserted multiple times into a 
section page, depending on how many products are in the section. When 
this happens, Actinic uses a 'list' to control the insertion of the layout into 
the page. 

If you look in the Design Tree, lists have the following icon - . 

The best way to select a list for editing is: 

1. Select an item in the design that is being laid out by a list. 

2. Click the 'Navigate to Parent Layout' icon -  - to select the 
list. 

To then edit the list layout, click the 'Edit List Layout Settings' button, or 
click the orange 'Click here to edit list layout settings' link at the top of 
the layout code. 

 

Exercise - Editing A List 
This exercise will show you how to change the layout of the 'New 
Products' list that is in the sidebar. 

If you don't have a new products list in the sidebar, use the best sellers 
list.  

1. Click on the 'New Products' text that's at the top of the new 
products list in the sidebar. This will select the entire list. 

2. Click the 'Edit List Layout Settings' button. 

 

3. Click the 'Edit' button next to the 'Start of List' field. 

4. Change the 'New Products' text to read 'New This Week'. 

 

5. Click 'OK' and then click 'Apply'.  

This should change the text that appears at the top of the list. 

More Information - Editing List Items 
If you want to edit the formatting of the actual items in the list, then you 
need to switch to the 'Edit Rows/Columns' tab within the list layout 
settings. 


